Instability with REST API and content negotiation
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted May 03, 2022 - 14:13 UTC
Update
The API has stabilized significantly, and we will continue to monitor the situation over the next several days.
Posted Apr 29, 2022 - 20:37 UTC
Update
We are still working on a fix for this but hope that we will have something implemented soon. More updates to follow.
Posted Apr 29, 2022 - 10:32 UTC
Update
We have identified that the API instability is being caused by a botnet querying for a very large volume of data. We are testing countermeasures today, and if the tests are successful, we will implement them tomorrow.
Posted Apr 28, 2022 - 16:44 UTC
Update
Polite and Plus server pools appear to be impacted again, along with Public. We believe that the identified cause still applies, and are continuing to monitor.
Posted Apr 28, 2022 - 14:47 UTC
Update
The performance problems we continue to see with the Public pool of the REST API appear to be the cause of user behavior. We continue to investigate how we can limit problems on that pool, but the very nature of the Public pool being anonymous can make it challenging to completely solve incidents like this. If you are on the Public API, you can avoid these issues by being Polite. As a reminder, you can do one of two things to be Polite (directed to the Polite pool): 1) Include a “mailto” parameter in your query OR 2) Include a “mailto:” in your User-Agent header. More on that here: https://0-api.crossref.org.libcat.lafayette.edu/swagger-ui/index.html.

Since we are still investigating problems in the Public pool, we will leave this issue open and provide updates as we have them. Since the issues appear to be confined to the Public pool of the REST API, those other pools (Polite and Plus) are all operational (and thus no longer included in this incident).
Posted Apr 27, 2022 - 19:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2022 - 17:19 UTC
Investigating
We continue to investigate the cause of the degraded performance.
Posted Apr 26, 2022 - 15:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2022 - 21:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2022 - 19:49 UTC
Update
We are continuing to investigate this issue.
Posted Apr 25, 2022 - 16:57 UTC
Investigating
We're seeing intermittent error messages on our REST API and with content negotiation. Our technical team is investigating, and we'll be back in touch when we know more.
Posted Apr 25, 2022 - 15:25 UTC
This incident affected: APIs (Public REST API, Polite REST API, Public content negotiation), Metadata Plus (Plus REST API), and Sites (Metadata search, Participation reports).